Compiz 0.7.4 available in my hardy PPA

I updated compiz and compiz-fusion to 0.7.4 over the weekend. The resulting packages are available in my PPA on launchpad. Feedback and testing is very welcome! The packages are at:

deb http://ppa.launchpad.net/mvo/ubuntu hardy main

apt-get install compiz should give you the latest compiz stuff. apt-get install simple-ccsm the latest configuration tools.

I will try to push this update into hardy but because we are already quite late in the freeze it will not be easy. The more feedback I get on this (both good and bad) the better the release team can judge if the update is safe for hardy or not. Please give it a whirl and let me know how it works for you🙂

29 Responses to “Compiz 0.7.4 available in my hardy PPA”

  1. Murat Says:

    This release has fixed random slowdowns with a NVIDIA GeForce Go6200 in my experience and has better overall performance. I’m able to use the “Best” texture filter with smooth animation in all plugins for the first time ever.

  2. dashua Says:

    I have been using your packages since Friday and they are running incredibly smooth on my Dell XPS m1530 with nVidia 8400 GS. The only bugs that are present are the pink decoratons under shadow for the window decoration plugin (which is possbily driver related) already reported. The animations are smoother and overall performance has increased.

    https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/198370

    This bug is still present and has been around for some time, not sure if there is a fix for it. I’ve been using Beryl / Compiz / Compiz Fusion for two years and would highly recommend these be included in Hardy.

  3. achim Says:

    As it seems this bug has been fixed with compiz 0.7.4

    https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/156055

    I have tested it with firefox3 and nautilus.

    At the moment I don’t see any new bugs.

    best wishes
    Achim

  4. Vadim P. Says:

    Any chance for a 7.10 backport? Or not feasible?

  5. Jan Van Besien Says:

    simple-ccsm fails to start:

    Traceback (most recent call last):
    File “/usr/bin/simple-ccsm”, line 425, in SetAnimationRating
    value = setting.Value[0]
    IndexError: list index out of range
    Traceback (most recent call last):
    File “/usr/bin/simple-ccsm”, line 425, in SetAnimationRating
    value = setting.Value[0]
    IndexError: list index out of range
    Traceback (most recent call last):
    File “/usr/bin/simple-ccsm”, line 425, in SetAnimationRating
    value = setting.Value[0]
    IndexError: list index out of range
    Traceback (most recent call last):
    File “/usr/bin/simple-ccsm”, line 949, in
    mainWin = MainWin(context, page)
    File “/usr/bin/simple-ccsm”, line 867, in __init__
    self.Update()
    File “/usr/bin/simple-ccsm”, line 877, in Update
    self.ProfilePage.Update()
    File “/usr/bin/simple-ccsm”, line 452, in Update
    self.SetAnimationRating()
    File “/usr/bin/simple-ccsm”, line 425, in SetAnimationRating
    value = setting.Value[0]
    IndexError: list index out of range

  6. JFM Says:

    Hi, this install broke my window behavior : a single click – instead of the normal double – on the titlebar of a window would maximize it. Very annoying.

    I’m back on 0.7.2, Thanks for the hard work, I hope it will make it (bugless) in Hardy’s final release as I quite like the hot corner delay feature.

    J-F.

  7. David Prieto Says:

    It seems the switcher uses the glide animation every time you call it. Other than that, this version seems to work just fine.

  8. forestpixie Says:

    Hi, it all seems to be working for me – well that is apart from the really annoying menu delay – so I’ve turned it off again.

  9. elefantcrossing Says:

    works great on my system (ati mobility radeon 9600 64mb with opensource ati drivers)
    with 7.2 i had hangs with dodge on focus and with rotating the cube

  10. garba Says:

    still suffering from corruption affecting window decorations sic the window title bar turns partly grey from time to time

  11. Michael Says:

    Working fine with a Dell XPS m1530 and a Nvidia 8600 GT.
    Hope this makes it into hardy.

  12. Antony Williams Says:

    no probs for me
    i vote it in for Hardy

  13. Murat Says:

    There’s some user feedback at http://ubuntuforums.org/showthread.php?t=748261 .

  14. Jonathan Says:

    Nearly everything is working fine, but it does seem to have introduced a strange blurriness on gnome-panel. Flicking wokspaces clears it up. Image http://www.mcmlxxii.co.uk/compiz74.png

    Also on login gnome-panel doesn’t appear until the screen is redrawn (workspace switched, Expo initiated etc). I only use one panel at the top of the screen and awn at the bottom.

    Graphics card is nvidia 6100, driver 169.12 from the hardy repos.

  15. Shafin Says:

    Had no problems at all,after some stress testing.

    The 3d plugin do not work,but it didnt work in 0.7.2 either.

  16. JayBee Says:

    I tried it and it has a lot of problems on my laptop (0.7.2 doesn’t have them).
    During any sort of animation, widnows become gray or black.
    When rotating cube, all windows and workspaces are in solid color, when windows wobble they are solid color (when I stop they come back).
    Menus are solid gray during opening animation…
    Here is a little screenshot:

    Laptop is HP Compaq 6710s with intel X3100 integrated graphics

  17. JayBee Says:

    link didn’t pass so here it is again

  18. Chris Coulson Says:

    As Jonathan above, I’m suffering with the ‘panel not appearing until screen is redrawn’ problem at login, as are quite a few other people on the Ubuntu forums. It confused me at first – I thought the panel was crashing

  19. Jonathan Says:

    One other thing I noticed was that a window closing whilst using the scale plugin caused the screen to freeze. In my case a file transfer finished just after I had initiated scale, the little file transfer window closed, and I couldn’t get out of scale without Ctrl + Alt + Bkspce.

  20. NullHead (ubuntuforums) Says:

    Well I tried the debs in the repository and compiz would segfault after I got it installed.

    uname -a
    Linux ubuntu804 2.6.24-15-generic #1 SMP Tue Apr 8 00:33:51 UTC 2008 i686 GNU/Linux
    
  21. Andrew Wood Says:

    Smoothest compiz yet!
    It even seems to solve the slight tearing of fullscreen video i always got with compiz on my nVidia fx5200

  22. joshrobinson Says:

    everything 100%
    i vote for it in hardy

  23. bh Says:

    The only issue, which is a pretty anoying one, is that the open effect is applied to switcher. Other than that things are working perfectly on i855

  24. joshrobinson Says:

    i just noticed an odd bug, after rotating the cube, sometimes the desktop looks blurred, the gnome panels are blurred, and dont clear up until i click or mouseover them

  25. JayBee Says:

    Hi, looks like my solid-color desktop and windows problem is connected with the Bicubic filter plugin. (Maybe my intel X3100 doesn’t support that)

  26. Jeremy Says:

    Any chance of getting the new wallpaper plugin in the compiz-fusion-plugins-extra package? With a dual-head setup, I’m drooling for it.

    Thanks!

  27. mariuz Says:

    seems that 0.7.4 is now by default in hardy (i have the rc)
    apt-cache show compiz
    Version: 1:0.7.4-0ubuntu6

  28. createmo Says:

    Thank you for your website🙂
    I made with photoshop backgrounds for myspace or youtube and whatever
    my backgrounds:http://tinyurl.com/6r7cav
    have a good day and thank you again!

  29. image hosting browse Says:

    Nice post! Im sure that this will be useful for lots of people.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: